KDYŽ (IF) | Excel – Funkce na podmínky

KDYŽ funkce je jedna z nejpoužívanějších v Excelu. V anglické verzi ji najdete jako funkci IF. Často se nám stane, že potřebujeme v tabulce otestovat, jestli je splněna určitá podmínka. Pokud je podmínka splněna (TRUE) chceme vrátit nějakou hodnotu a pokud podmínka splněna není (FALSE), chceme vrátit hodnotu jinou. Přesně k tomuto je tato funkce navržena.

Co do Excel funkce KDYŽ (IF) vyplnit?

Vzorec vypadá takto:

=KDYŽ(podmínka; hodnota když je podmínka splněna; hodnota když není splněna) (česká verze Excelu) nebo…

=IF(podmínka; hodnota když je podmínka splněna; hodnota když není splněna) (US verze Excelu)

Excel funkce KDYŽ

Funkce má 3 argumenty:

Podmínka – Tady vyplníme podmínku většinou s použitím matematických operátorů (<>=), např. buňka A1 = buňka B2 nebo jakoukoliv jinou podmínku co nás napadne

Ano – Hodnota, kterou má funkce vrátit v případě, že je podmínka (viz. dříve) splněna.

Ne – Hodnota, kterou má funkce vrátit v případě, že není podmínka splněna

Příklad

Zkusíme si opět vymyslet praktický příklad, na kterém bychom si funkci když ukázali. Z Českého statistického úřadu jsem si stáhnul Excel se statistikami výdajů domácností na spotřebu. Excel obsahuje informace o výdajích českých domácností na různé účely (potraviny, bydlení apod). Pokusíme se ji trošku zanalyzovat :).


Excel s daty si můžete stáhnout tady 


Zadání praktického úkolu na využití excel funkce KDYŽ

Zadání praktického úkolu

Tak jdeme na to a zkusíme si napsat vzorec:

Argumenty Funkce – budeme porovnávat hodnoty ve sloupci B a C. Chceme otestovat, jestli je výdaj domácnosti v roce 2015 vyšší než v roce 2014. Do buňky D6 tedy napíšeme

=KDYŽ(C6>B6;“Vyšší“;“Nižší nebo rovno“)

Píšeme vzorec excel funkce KDYŽ

Buňky dále rozšíříme směrem dolů. Úkol je splněn, ještě bychom si mohli výsledek zpřehlednit a do vedlejšího sloupce zobrazit o kolik se spotřeba domácností změnila v % spolu s podmíněným formátováním, tak aby byl výsledek barevně rozlišený:

Řešení úkolu excel funkce KDYŽ

Řešení úkolu

Vnořená KDYŽ

Speciálním variantou použítí funkce je pokud použijeme funkci několikrát v jednom vzorci. Tuto metodu používáme tehdy , pokud potřebujeme otestovat více než 1 podmínku. V našem případě jsme výdaje domácností rozdělili na 2 části dle porovnáni spotřeby roku 2014 a 2015:

  • Vyšší
  • Nižší nebo rovno

To je hezké, ale co kdybychom chtěli mít nižší a stejnou spotřebu zvlášť, jinými slovy chtěli bychom 3 skupiny:

  • Vyšší
  • Nižší
  • Rovno

Jednoduše použijeme funkci ve vzorci dvakrát.

=KDYŽ(C6>B6;“Vyšší“; KDYŽ(C6=B6;“Rovno“;“Nižší“))

Co jsme vlastně napsali – Pokud je hodnota v roce 2015 vyšší, tak přiřadíme hodnotu „Vyšší“ a pokud ne tak KDYŽ je hodnota v roce 2015 stejná jako v roce 2014, přiřadíme „Rovno“ a v ostatních případech přiřadím „Nižší“

Řešení úkolu

Příklad použití vnořené funkce

To je vše, Excel s řešením Vám nabízím ke stažení – Výdaje domácností_řešení

Reagovat na příspěvek