SUMA (SUM) | Excel – Součet hodnot v tabulce

Funkce SUMA, anglicky SUM, patří k nejzákladnějším funkcím Excelu a řadíme je do matematických funkcí. Tato funkce provádí součet hodnot v zadané oblasti buněk. Pokud hodnoty v excelu sčítáte stále jednu po druhé přes +, tak toto je funkce přesně pro vás 🙂

Zápis funkce SUMA – pro součet hodnot v Excelu

=SUMA(oblast buněk) (česká verze Excelu) nebo…

=SUM(oblast buněk) (US verze Excelu)

Příklad na funkci SUMA (SUM) – Jak funkci použít?

Praktické použítí si ukážeme na příkladu v Excelu. Představte si, že máte jednoduchou tabulku s čísly podobné této tabulce. Budeme mít za úkol hodnoty z Excel tabulky sečíst. Jak na to?

Zadání příkladu na funkci SUMA (SUM)

1) Varianta sčítání přes + je všechny hodnoty z Excel tabulky sečíst přes znaménko sčítání + což není zdaleka ideální 🙂 Výsledek vypadá hrozně a je časově náročný – zejména pokud máme v tabulce desítky, stovky nebo více záznamů (viz níže).

Obyčejné sčítání bez použítí funkce

2) Varianta sčítání přes funkci SUMA (SUM) – Výsledek máme vypočítaný v Excelu mnohem rychleji

Vzorec na součet v Excelu nemusíme vždy psát – použijte vychytávku

Některé základní funkce v excelu má Excel pro použití již připravené. Konkrétně funkci SUMA najdeme v nabídce na kartě VZORCE – Automatické shrnutí, viz obrázek. Pozor – když vybíráte součet přes tuto možnost, tak musíte stát v buňce, ve které chcete mít požadovaný součet.

Funkce suma přes automatické shrnutí

Pozor na filtr při použítí funkce pro sčítání

V případě, že máme tabulku nad kterou použijeme filtr, tak funkce filtr ignoruje. Na to musíme dávat pozor – viz obrázek níže. Vzorec =SUMA(B8:B18) dává součet 695 i když viditelné hodnoty jsou pouze 30, 24. Ostatní hodnoty jsou odfiltrovány, nicméně funkce SUMA je započítává.

Co s tím? Pokud chcete, aby SUMA počítala pouze viditelné hodnoty, tak musíte tabulku nejprve oblast zformátovat jako tabulku a pak už to bude fungovat podle očekávání:

Formátovat jako tabulku v Excelu

 

Reagovat na příspěvek