Geometrický průměr v Excelu (GEOMEAN) – Jak na to?

Geometrický průměr je statistická veličina, která se nejvíce používá pro vypočítání tempa růstu v čase. V minulém článku jsem se věnoval tomu, jak pomocí Excel funkcí vypočítat v Excelu vážený aritmetický průměr (viz článek Vážený průměr v Excelu) a dnes se podíváme na Geometrický průměr.

Vzorec na geometrický průměr

Průměr geometrický se počítá podobně jako aritmetický průměr prostý, jen se místo sčítání (aritmetický průměr) používá násobení a místo dělení (aritmetický průměr) se používá odmocnina. Vzorec vypadá takto.

Geometrický průměr - vzorec

Geometrický průměr je vždy menší nebo roven aritmetickému průměru.

Jak vypočítat geometrický průměr v Excelu pomocí funkce GEOMEAN

Zadání příkladu: Na webu České národní banky najdeme data k meziměsíčnímu růstu inflace v České republice. Data najdete na tomto odkaze a můžete si je vyexportovat do Excelu. Obsahují míry růstu inflace. Pomocí geometrického průměru vypočítáme průměrnou inflaci (čili jak dlouhodobě roste cenová hladina) za období od 1.1.2017 v České republice. Pro srovnání spočítáme také aritmetický průměr prostý.

1) Připravíme si excelovský soubor – zajímat nás budou sloupce čistá inflace a období od 1.1.2017, ostatní můžeme smazad

2) Aritmetický průměr spočítáme jako součet všech hodnot vydělený počtem hodnot. Tzn SUMA/POČET. Pro průměr geometrický použijeme vestavěnou Excelovskou funkci GEOMEAN. Stačí napsat funkci a jako argument fložit pole s hodnotami (viz obrázek).

Vzorec na aritm. průměr: =SUMA(B7:B23)/POČET(B7:B23)
Vzorec na geom. průměr: =GEOMEAN(B7:B23)

Příklad na výpočet geometrického průměru - ŘEŠENÍ

 

Zdroje:

_______________________________________________________________________________________________
Intelligent technologies - podniková řešení a školení
Stránkonoš.cz - webové stránky za rozumnou cenu
Geometrický průměr v Excelu (GEOMEAN) – Jak na to?
4 (80%) 1 vote

Napsat komentář

Vaše emailová adresa nebude zveřejněna.

This site uses Akismet to reduce spam. Learn how your comment data is processed.